Брокер IPv6

Ваш оператор застрял в прошлом веке и не собирается выдавать IPv6, значит это повод получить свой IPv6 префикс /48 от IPv6 брокера.

Заказав настройку MikroTik, вы получите 100% проработанное решение от опытного сетевого инженера.

Для работы с туннельным брокером нужен белый IPv4 адрес. Но есть способы прогнать через CHR на VDS

Регистрация

Регистрируем на https://ipv6.ip4market.ru/ и входим по логину и паролю в кабинет

Брокер ipv6.ip4market.ru
Видим настройки, где
Server IPv4 — сервер брокера
Client IPv4 — ваш белый IP

Так же брокер дает ссылку, по которой можно обновлять настройку при смене IP

Настройка

Настройка для разных типов подключений будет отличаться только размером MTU

Брокер IPv6
В моем случае оператор предоставляет белый IP по PPPoE, чем уменьшает размер MTU до 1480, а это значит нужно уменьшить MTU на 20 байт для 6to4 туннеля.

Для IPoE или Static IP размер MTU будет вычитаться из MTU интерфейса 1500, то есть 1480.

Брокер IPv6
Interface
Создаем 6to4 интерфейс
/interface 6to4
add !keepalive local-address=93.157.169.199 mtu=1460 name=6to4 remote-address=193.0.203.203
Брокер IPv6
И вешаем из кабинета брокера Client IPv6 адрес
/ipv6 address
add address=2a03:e2c0:27df::2 advertise=no interface=6to4
Брокер IPv6
Добавляем маршрут по умолчанию в Routed /48 IPv6 network
MikroTik изменит адрес до туннельного
/ipv6 route
add disabled=no distance=1 dst-address=::/0 gateway=2a03:e2c0:27df::1 routing-table=main scope=30 suppress-hw-offload=no target-scope=10
Брокер IPv6
IPv6 > Addresses
Вешаем адрес на интерфейс локальной сети адрес Routed /64 IPv6 network и включаем Advertise
/ipv6 address

add address=2a03:e2c0:27df:5555:: interface=bridgeLAN
Брокер IPv6
IPv6 > ND
Выставляем MTU как на туннеле
/ipv6 nd
set [ find default=yes ] interface=bridgeLAN mtu=1460

Если удаляли настройки Firewall IPv6, лучше его настроить заново, так как устройства стали доступны из интернета по белым IP

/ipv6 firewall address-list
add address=::/128 comment="defconf: unspecified address" list=bad_ipv6
add address=::1/128 comment="defconf: lo" list=bad_ipv6
add address=fec0::/10 comment="defconf: site-local" list=bad_ipv6
add address=::ffff:0.0.0.0/96 comment="defconf: ipv4-mapped" list=bad_ipv6
add address=::/96 comment="defconf: ipv4 compat" list=bad_ipv6
add address=100::/64 comment="defconf: discard only " list=bad_ipv6
add address=2001:db8::/32 comment="defconf: documentation" list=bad_ipv6
add address=2001:10::/28 comment="defconf: ORCHID" list=bad_ipv6
add address=3ffe::/16 comment="defconf: 6bone" list=bad_ipv6
/ipv6 firewall filter
add action=accept chain=input comment="defconf: accept established,related,untracked" connection-state=established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=invalid
add action=accept chain=input comment="defconf: accept ICMPv6" protocol=icmpv6
add action=accept chain=input comment="defconf: accept UDP traceroute" port=33434-33534 protocol=udp
add action=accept chain=input comment="defconf: accept DHCPv6-Client prefix delegation." dst-port=546 protocol=udp src-address=fe80::/10
add action=accept chain=input comment="defconf: accept IKE" dst-port=500,4500 protocol=udp
add action=accept chain=input comment="defconf: accept ipsec AH" protocol=ipsec-ah
add action=accept chain=input comment="defconf: accept ipsec ESP" protocol=ipsec-esp
add action=accept chain=input comment="defconf: accept all that matches ipsec policy" ipsec-policy=in,ipsec
add action=drop chain=input comment="defconf: drop everything else not coming from LAN" in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept established,related,untracked" connection-state=established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" connection-state=invalid
add action=drop chain=forward comment="defconf: drop packets with bad src ipv6" src-address-list=bad_ipv6
add action=drop chain=forward comment="defconf: drop packets with bad dst ipv6" dst-address-list=bad_ipv6
add action=drop chain=forward comment="defconf: rfc4890 drop hop-limit=1" hop-limit=equal:1 protocol=icmpv6
add action=accept chain=forward comment="defconf: accept ICMPv6" protocol=icmpv6
add action=accept chain=forward comment="defconf: accept HIP" protocol=139
add action=accept chain=forward comment="defconf: accept IKE" dst-port=500,4500 protocol=udp
add action=accept chain=forward comment="defconf: accept ipsec AH" protocol=ipsec-ah
add action=accept chain=forward comment="defconf: accept ipsec ESP" protocol=ipsec-esp
add action=accept chain=forward comment="defconf: accept all that matches ipsec policy" ipsec-policy=in,ipsec
add action=drop chain=forward comment="defconf: drop everything else not coming from LAN" in-interface-list=!LAN

Проверка подключения

Брокер IPv6
Сайт https://www.test-ipv6.com/ показывает состояние подключения IPv6

Так же сайт настройка-микротик.рф работает по IPv6