IPv6 LTE kit

Настройка LTE kit MikroTik для работы IPv6 адреса от мобильных операторов. В данном примере настройка IPv6 от МегаФон с услугой «Открытый IPv6». Для МТС, Билайн, Теле2 настройка будет аналогичной.

Заказав настройку MikroTik, вы получите 100% проработанное решение от опытного сетевого инженера.
Открытый IPv6
Так выглядит опция от МегаФона
IPv6 LTE kit
Стандартный LTE6 модем
IPv6 на lte1
При подключении LTE он получает динамический глобальный IPv6 адрес
Так же каждый интерфейс по умолчанию имеет динамический локальный адрес, который работает в пределах свой сети и не маршрутизируется.
IPv6 LTE kit
Так как оператор даёт всего один IPv6 адрес, создаем уникально-локальный адрес fc::1/64, который начинается на fc или fd
И сообщаем по SLAAC в сеть какой у нее адрес через Advertise
IPv6 LTE kit
Вешаем IPv6 DNS сервера
IPv6 LTE kit
Так как сотовые операторы дают один IPv6 ::/64 адрес, настраиваем NAT
IPv6 LTE kit
Настраиваем маскарад, так как IPv6 адрес на lte интерфейсе постоянно меняется.

Проверка работы

 ping [:resolve ipv6.google.com]            
  SEQ HOST                                     SIZE TTL TIME       STATUS                                                                                                                                                                                  
    0 2a00:1450:400f:804::200e                   56 112 85ms802us  echo reply                                                                                                                                                                              
    1 2a00:1450:400f:804::200e                   56 112 84ms613us  echo reply                                                                                                                                                                              
    2 2a00:1450:400f:804::200e                   56 112 83ms54us   echo reply                                                                                                                                                                              
    3 2a00:1450:400f:804::200e                   56 112 82ms503us  echo reply                                                                                                                                                                              
    4 2a00:1450:400f:804::200e                   56 112 89ms516us  echo reply                                                                                                                                                                              
    5 2a00:1450:400f:804::200e                   56 112 85ms760us  echo reply                                                                                                                                                                              
    6 2a00:1450:400f:804::200e                   56 112 84ms437us  echo reply                                                                                                                                                                              
    7 2a00:1450:400f:804::200e                   56 112 84ms201us  echo reply                                                                                                                                                                              
    8 2a00:1450:400f:804::200e                   56 112 84ms886us  echo reply                                                                                                                                                                              
    9 2a00:1450:400f:804::200e                   56 112 83ms774us  echo reply                                                                                                                                                                              
    sent=10 received=10 packet-loss=0% min-rtt=82ms503us avg-rtt=84ms854us max-rtt=89ms516us

Минимально рабочий конфиг для запуска IPv6 (при условии правильной настройки LTE)

/ipv6 address
add address=fc::1 interface=ether1

/ipv6 firewall nat
add action=masquerade chain=srcnat out-interface=lte1

Не забываем про Firewall:

/ipv6 firewall address-list
add address=::/128 comment="defconf: unspecified address" list=bad_ipv6
add address=::1/128 comment="defconf: lo" list=bad_ipv6
add address=fec0::/10 comment="defconf: site-local" list=bad_ipv6
add address=::ffff:0.0.0.0/96 comment="defconf: ipv4-mapped" list=bad_ipv6
add address=::/96 comment="defconf: ipv4 compat" list=bad_ipv6
add address=100::/64 comment="defconf: discard only " list=bad_ipv6
add address=2001:db8::/32 comment="defconf: documentation" list=bad_ipv6
add address=2001:10::/28 comment="defconf: ORCHID" list=bad_ipv6
add address=3ffe::/16 comment="defconf: 6bone" list=bad_ipv6
/ipv6 firewall filter
add action=accept chain=input comment="defconf: accept established,related,untracked" connection-state=established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=invalid
add action=accept chain=input comment="defconf: accept ICMPv6" protocol=icmpv6
add action=accept chain=input comment="defconf: accept UDP traceroute" port=33434-33534 protocol=udp
add action=accept chain=input comment="defconf: accept DHCPv6-Client prefix delegation." dst-port=546 protocol=udp src-address=fe80::/10
add action=accept chain=input comment="defconf: accept IKE" dst-port=500,4500 protocol=udp
add action=accept chain=input comment="defconf: accept ipsec AH" protocol=ipsec-ah
add action=accept chain=input comment="defconf: accept ipsec ESP" protocol=ipsec-esp
add action=accept chain=input comment="defconf: accept all that matches ipsec policy" ipsec-policy=in,ipsec
add action=drop chain=input comment="defconf: drop everything else not coming from LAN" in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept established,related,untracked" connection-state=established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" connection-state=invalid
add action=drop chain=forward comment="defconf: drop packets with bad src ipv6" src-address-list=bad_ipv6
add action=drop chain=forward comment="defconf: drop packets with bad dst ipv6" dst-address-list=bad_ipv6
add action=drop chain=forward comment="defconf: rfc4890 drop hop-limit=1" hop-limit=equal:1 protocol=icmpv6
add action=accept chain=forward comment="defconf: accept ICMPv6" protocol=icmpv6
add action=accept chain=forward comment="defconf: accept HIP" protocol=139
add action=accept chain=forward comment="defconf: accept IKE" dst-port=500,4500 protocol=udp
add action=accept chain=forward comment="defconf: accept ipsec AH" protocol=ipsec-ah
add action=accept chain=forward comment="defconf: accept ipsec ESP" protocol=ipsec-esp
add action=accept chain=forward comment="defconf: accept all that matches ipsec policy" ipsec-policy=in,ipsec
add action=drop chain=forward comment="defconf: drop everything else not coming from LAN" in-interface-list=!LAN

Сайт https://www.test-ipv6.com/ показывает состояние подключения IPv6

Так же сайт настройка-микротик.рф работает по IPv6