Быстрый переключатель WAN

Для быстрого ручного переключения между провайдерами я использую скрипты, которые меняют distans маршрута.

Для его работы нужно проставить комментарии на нужные маршруты:

  • WAN1_Recursive
  • WAN2_Recursive
  • WAN3_Recursive
/system script
add dont-require-permissions=no name=WAN1>WAN2>WAN3 owner=WinBox policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source=\
"/ip route set [find comment=\"WAN1_Recursive\"] distance=10\r\
\n/ip route set [find comment=\"WAN2_Recursive\"] distance=20\r\
\n/ip route set [find comment=\"WAN3_Recursive\"] distance=30"
add dont-require-permissions=no name=WAN1>WAN3>WAN2 owner=WinBox policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source=\
"/ip route set [find comment=\"WAN1_Recursive\"] distance=10\r\
\n/ip route set [find comment=\"WAN3_Recursive\"] distance=20\r\
\n/ip route set [find comment=\"WAN2_Recursive\"] distance=30"
add dont-require-permissions=no name=WAN2>WAN1>WAN3 owner=WinBox policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source=\
"/ip route set [find comment=\"WAN2_Recursive\"] distance=10\r\
\n/ip route set [find comment=\"WAN1_Recursive\"] distance=20\r\
\n/ip route set [find comment=\"WAN3_Recursive\"] distance=30"
add dont-require-permissions=no name=WAN2>WAN3>WAN1 owner=WinBox policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source=\
"/ip route set [find comment=\"WAN2_Recursive\"] distance=10\r\
\n/ip route set [find comment=\"WAN3_Recursive\"] distance=20\r\
\n/ip route set [find comment=\"WAN1_Recursive\"] distance=30"
add dont-require-permissions=no name=WAN3>WAN1>WAN2 owner=WinBox policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source=\
"/ip route set [find comment=\"WAN3_Recursive\"] distance=10\r\
\n/ip route set [find comment=\"WAN1_Recursive\"] distance=20\r\
\n/ip route set [find comment=\"WAN2_Recursive\"] distance=30"
add dont-require-permissions=no name=WAN3>WAN2>WAN1 owner=WinBox policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source=\
"/ip route set [find comment=\"WAN3_Recursive\"] distance=10\r\
\n/ip route set [find comment=\"WAN2_Recursive\"] distance=20\r\
\n/ip route set [find comment=\"WAN1_Recursive\"] distance=30"