Рекурсивная маршрутизация MikroTik

Рекурсивная маршрутизация на MikroTik используется для проверки доступности интернета за шлюзом оператора, так как доступность шлюза не всегда означает доступность интернета.

Заказав настройку MikroTik, вы получите 100% проработанное решение от опытного сетевого инженера.

Система работает на Scope и Target Scope и щепотке сетевой магии, когда маршрут по умолчанию настроен на адрес в интернете, который доступен через шлюз провайдера. При этом check-gateway мы уже можем ставить и на шлюз и на удаленный адрес.

Если вам нужна практическая настройка 2WAN с рекурсивной маршрутизацией и дополнительной проверкой — есть отдельная статья 2WAN RouterOS 7.

RouterOS 7

Рекурсивная маршрутизация RouterOS 7 MikroTik
Рекурсивная маршрутизация RouterOS 7
/ip route

add comment=WAN1_!_Recursive disabled=no distance=1 dst-address=4.2.2.1/32 gateway=79.174.41.129 pref-src="" routing-table=main scope=11 suppress-hw-offload=no target-scope=10
add comment=WAN2_!_Recursive disabled=no distance=1 dst-address=4.2.2.2/32 gateway=80.76.108.1 pref-src="" routing-table=main scope=11 suppress-hw-offload=no target-scope=10
add comment=WAN3_!_Recursive disabled=no distance=1 dst-address=4.2.2.3/32 gateway=192.168.199.1 pref-src="" routing-table=main scope=11 suppress-hw-offload=no target-scope=10
add comment=WAN1_Recursive disabled=no distance=10 dst-address=0.0.0.0/0 gateway=4.2.2.1 pref-src="" routing-table=main scope=30 suppress-hw-offload=no target-scope=11
add check-gateway=ping comment=WAN2_Recursive disabled=no distance=20 dst-address=0.0.0.0/0 gateway=4.2.2.2 pref-src="" routing-table=main scope=30 suppress-hw-offload=no target-scope=11
add comment=WAN3_Recursive disabled=no distance=30 dst-address=0.0.0.0/0 gateway=4.2.2.3 pref-src="" routing-table=main scope=30 suppress-hw-offload=no target-scope=11

В примере будет использоваться 3 оператора:

  1. WAN1 — шлюз 79.174.41.129, проверка 4.2.2.1
  2. WAN2 — шлюз 80.76.108.1, проверка 4.2.2.3
  3. WAN3 — шлюз 192.168.199.1, проверка 4.2.2.3
Рекурсивная маршрутизация WAN1
Указываем шлюз 4.2.2.1
Рекурсивная маршрутизация MikroTik
Который доступен через шлюз оператора
Рекурсивная маршрутизация WAN2
Для 2 оператора так же указываем шлюз 4.2.2.2
Рекурсивная маршрутизация MikroTik
Который доступен через шлюз второго оператора