OSPF MikroTik на RouterOS 7

Настройка RouterOS 7 OSPF существенно отличается от Ros6, основная сложность в фильтрах и настройка соседства на интерфейсах.

Заказав настройку MikroTik, вы получите 100% проработанное решение от опытного сетевого инженера.
RouterOS 7 OSPF с официального сайта
RouterOS 7 OSPF полностью описан в официальной справке https://help.mikrotik.com/docs/display/ROS/OSPF

Подготовка RouterOS 7 OSPF

Lo интерфейс

В MikroTik обычно его не создают, так как есть bridge, который объединяет порты и всегда активен, но в нашем случае он применяется. Подробнее про Lo.

Bridge > Bridge Создаем интерфейс lo
Bridge > Bridge
Создаем интерфейс lo
/interface bridge
add name=lo

RouterID

Routing > Router ID Задаем название, ID в качестве IP адреса Lo интерфейса, а так же only loopback
Routing > Router ID
Задаем название, ID в качестве IP адреса Lo интерфейса, а так же only loopback
/routing id
add disabled=no id=10.255.0.1 name=lo select-dynamic-id=only-loopback

OSPF

Instances

Объявляем о connected маршрутах и применяем обязательно фильтры
Объявляем о connected маршрутах и применяем обязательно фильтры
/routing ospf instance
add disabled=no in-filter-chain=ospf-in name=ospf-office out-filter-chain=ospf-out redistribute=connected router-id=lo

Areas

Без backbone OSPF не может работать, создаем ее, либо если она на другом маршрутизаторе, создаем другой Area и подключаем к Backbone
Без backbone OSPF не может работать, создаем ее, либо если она на другом маршрутизаторе, создаем другой Area и подключаем к Backbone
/routing ospf area
add disabled=no instance=ospf-office name=ospf-area-backbone-office

Interfaces Templates

Указываем какие интерфейсы для обмена маршрутов по OSPF Можно указывать как интерфейс, так и сеть, либо их комбинацию
Указываем какие интерфейсы для обмена маршрутов по OSPF
Можно указывать как интерфейс, так и сеть, либо их комбинацию
/routing ospf interface-template
add area=ospf-area-backbone-office cost=200 disabled=no interfaces=l2tp-Office_WAN1 networks=172.31.255.8/30 type=ptp
add area=ospf-area-backbone-office cost=300 disabled=no interfaces=l2tp-Office_WAN2 networks=172.31.255.12/30 type=ptp
add area=ospf-area-backbone-prod cost=200 disabled=no interfaces=l2tp-Prod_WAN1 type=ptp
add area=ospf-area-backbone-prod cost=300 disabled=no interfaces=l2tp-Prod_WAN2 type=ptp

Neighbors

Состояние Full - значит соседство установилось
Состояние Full — значит соседство установилось

OSPF Filters Rule

Используется новый стиль фильтров OSPF, вот несколько примеров:

Фильтры OSPF RouterOS 7
Фильтры OSPF RouterOS 7
/routing filter rule
add chain=ospf-in disabled=no rule="if (dst-len in 32 && dst in 10.255.0.0/24) {accept}"
add chain=ospf-in disabled=no rule="if (dst in 192.168.120.0/24) {accept}"
add chain=ospf-in disabled=no rule="if (dst in 192.168.130.0/24) {accept}"
add chain=ospf-out disabled=no rule="if (dst-len in 32 && dst in 10.255.0.0/24) {accept}"
OSPF MikroTik на RouterOS 7
Не хватает конструктора 🙂

Разрешаем все маршруты с маской /32 до сети 10.255.0.0/24

if (dst-len in 32 && dst in 10.255.0.0/24) {accept}

Разрешаем маршрут до 192.168.120.0/24

if (dst in 192.168.120.0/24) {accept}